System switch (mac)

Things I have tried

I can’t see this addressed, so apologies if it’s a duplicate – is there some way on a Mac of stopping the appearance of Obsidian switching to the system dark / light mode on a mac? I have found the “Dark” version of the Pisum theme is great, but since my OS is in Light mode, when I restart Obsidian it resorts to the Light version of Pisum (which I don’t want).

What I’m trying to do

Stop Obsidian from matching system Light/Dark mode.

In Obsidian, is “Settings > Appearance > Base Theme” set to “Light” or “Dark”?


It can be set on either, the problem is that it seems to revert to whichever the OS is set to when I restart Obsidian.

Quite often in that setting it gives “Light / Dark / System” as options, but I don’t see that here.


I am on a Mac with, I think, the same settings as the ones you describe (light mode in Apple > System Preferences > General > Appearance, and light mode in Obsidian), and I am not seeing the same as you if I enable the Pisum theme. I am running the beta of macOS 12 Monterey, so that might be significant.

Don’t know why you are experiencing the issue that you are, but as a workaround you can add a shortcut under ‘Obsidian > Settings > Hotkeys > Use dark mode’ to make it relatively easy to switch dark mode on again without having to go into the settings each time.

Hope someone has a real solution for you.


Edit: See this thread, which says auto switching isn’t a thing, unless a plug-in or css snippet is being used.

Kepano added that in his plugins as a feature recently, perhaps that’s why it happens?

I see, thank you for the suggestions.

I just tried it with a different theme (Minimal) and with none, and I observe the same switching. If I am in Light mode on the OS and I switch to Dark in the Obsidian settings, it goes Dark of course. But if I quit and reopen Obsidian it opens in the Light version of Minimal. (Same works in opposite direction if the OS is Dark and I set the theme to the Light). So it’s not the particular theme.

I’m not on the Monterey beta, so it could be that upgrading would fix, though I’m not brave enough on my main machine.

In the meantime I have chomped away at the Pisum CSS code to make all reference to dark and light the same. I probably broke something, but now my Light mode looks like a Dark mode. The silly thing is that the Pisum CSS doesn’t have an actual Light or Dark, it switches to the Andy sliding panes thing in the Light mode, which I can’t be doing with.

Ok – I may have tipped you off there. I mentioned the Minimal Theme. It has its own Minimal Theme Settings plugin. I turned that off and found the switching to system theme no longer happened. Indeed, there is a setting in the Minimal Theme plugin which optionally matches system theme. I disabled the plugin now, but toggling that option also solved the problem.

Thanks though!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.