System dictation on macOS jumping and creating duplicate text

Steps to reproduce

Dictate text “This is a test of dictation”

Expected result

This is a test of dictation

Actual result

TThis is a test of dictation
This is a


  • Operating system: macOS 12.0.1 (Intel iMac 5K)
  • Obsidian version: 0.13.8

Consistent problem, even with a clean, default vault and no plugins or third-party themes. If I toggle the “Legacy editor” on (and restart Obsidian), the problem goes away, but returns once I return to non-legacy mode.

Additional information

This has been brought up before on Discord:

After the update of 0.13.9, two changes:

  1. Now, if I turn on Legacy mode, I’m unable to initiate (macOS system) dictation.
  2. With Legacy mode off, the effect is even worse in Live Preview mode, where dictating “This is a test of dictation” generates multiple lines:

This is a
This is a test
This is a test
This is a test ofTThis is a test of dictation
This is a test of the

does it happen in source mode?

With the update to 0.13.10 the situation is the same:

  1. With Legacy Editor toggled on, I can use the macOS system dictation, but while I am dictating, the text is all underlined and none of the paragraph breaks that I dictate (“New Paragraph”) are visible, until I stop dictating, and then the paragraph breaks are visible and the underlining disappears.
  2. With Legacy Editor toggle off, and get the duplication mentioned in my earlier post – whether it’s in Source mode or Live Preview mode.

This isn’t marked as solved.

This is now solved for me, with the recent updates.

Good to know.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.