Sync causing default keybinding stop working

I find that if i enabled sync on macbook than enable it on ubuntu. All ubuntu obsidian’s keybinding stop working.

I have one macbook and two linux (ubuntu) machine in differnet place.

On macbook, obsidian is latest version downloaded from official website.
On ubuntu, obsidian is installed with flatpak.

Steps to reproduce

To reproduce the issue:

  1. Enable sync on ubuntu A
  2. Enable sync on macbook
  3. Visit ubuntu A, all keybindings stop working
  4. Visit ubuntu B, enable sync, all keybinding stop working (Confirmed)

Expected result

All keybindings work as before on ubuntu

Actual result

Ubuntu keybindings stop working, even the ctrl+p


  • Operating system:

    • ubuntu
    • macbook
  • Obsidian version:

    • 0.12.12

Does it happen with appimage? Have you tried in vault with no thirdparty plugins?

I am not sure with appimage. I disabled all third party plugins, it still not work. After some experiment, i reset .obsidian/hotkeys.json file to empty content {} , than it works again.