Strange Quick Switcher Results

Things I have tried

Renaming files and aliases

What I’m trying to do

When I open the quick switcher using cmd - O, I don’t understand the results.
e.g.

  1. While most files are listed by the file name, some are listed also with the path in front of the name (not under it as with aliases). I thought the path was only if there were two files with the same name, and then it displayed each with the path in front. Am I correct on this assumption? I also thought maybe because some of these files had the same aliases, but when deleting them, it made no difference. You can see in the screenshot how “Elections, German” & “Elections, American” starts with the file name, but under those, instead of starting with the file name, it starts with the path to the next file.
    Screen Shot 2022-03-30 at 09.16.18

  2. Sometimes when I search using an apostrophe, such as “Smith’s . . .” I only get a single result, but when I search using just “Smith” I get all the results. However, other times, searching the same term with the apostrophe works. No clue why is sometimes does and sometimes doesn’t.

  3. I don’t know if this is related, but I have a post in obsidian mobile about my iCloud files not showing up on the phone if they are not in one of my interior folders in obsidian.
    Obsidian Mobile

Actually I made an error. For case #2 above, when using the quick switcher, queries w/ an apostrophe are fine, but when in a note starting with the two open brackets “[[” and looking at the auto-populated results, using an apostrophe finds one file only, but w/o, it finds all my files that have the apostrophe. Still no clue as to why. Feels like something is wrong.