Spacing when including heading

I’m having this annoying spacing issue when including sub-parts of one note into another note. See thread below for details… Any help appreciated.

I often factor larger notes into smaller “atomic” notes, and then include them in the larger notes through Obsidians ![[link]] mechanism…

Here’s a file (Bloo) I want to include in another file (Blah). Here’s Bloo:

When I include the whole file into Blah it looks fine:

Or in preview mode:

But (obviouslly) the whole content of the note is included, which may include stuff I manually maintain like last edit date, side-notes I’d add at the end, etc. So what I actually want to do is to include what’s under the blah heading, and that’s where the issue lies, at it looks like this:

Screenshot 2023-07-21 at 12.31.01

And in preview mode, with issue highlighted:

Is there any way to suppress this space from happening? Is it intentional?

As an aside, can one suppress the note title or included heading from being inserted?

In case it’s relevant, I’m using the minimal theme.

1 Like

It is the double indentation that I don’t like when using transcluded elements with blockquotes. It is superfluous.

Using Minimal, there are a few settings for embeds in Style Settings you can try:

And for even more control (with Minimal’s settings off) you could try SlRvb’s embed snippet:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.