Source Mode flag appears to get out sync with true state

Steps to reproduce

  1. Open Sandbox Vault
  2. Select View → Source Mode
  3. Select View → Reading Mode
  4. Unselect View → Source Mode
  5. Unselect View → Reading Mode
  6. Toggle Source Mode off and on and notice that it now has the opposite effect

Did you follow the troubleshooting guide? Y

Expected result

I expect that turning Source Mode on (checkmark visible in View drop down) causes me to see all markdown and turning Source Mode off (checkmark not visible in View drop down) causes me to see the Live Preview.

Actual result

Turning Source Mode on (checkmark visible in View drop down) causes me to see the Live Preview and turning Source Mode off (checkmark not visible in View drop down) causes me to see all markdown.

Environment

SYSTEM INFO:
Obsidian version: v1.5.3
Installer version: v1.5.3
Operating system: Darwin Kernel Version 23.2.0: Wed Nov 15 21:53:18 PST 2023; root:xnu-10002.61.3~2/RELEASE_ARM64_T6000 23.2.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: on

RECOMMENDATIONS:
none


Additional information


Thanks!

1 Like

was fixed 1.5.4

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.