[SOLVED] Markdown render childes are not being unloaded when switching notes in the same tab

Steps to reproduce

  1. download or clone the plugin that showcases the bug here
  2. navigate to the showcase vault and open it as a vault in obsidian
  3. enable community plugins
  4. enable the Load Unload Bug Report plugin
  5. follow the steps outlined in the file Steps to reproduce the bug (the file is inside of the vault) (link to the file on github)

Expected result

When switching the file in a tab, all markdown render children of the original file should be unloaded once. And then all markdown render children of the new file should be loaded once. Both in live preview and reading mode.

Described in more detail in the Steps to reproduce the bug file (link to the file on github)

Actual result

In live preview, markdown render children only get closed, when the tab is closed.

In reading mode, multiple markdown render children are created per code block. Some render children get unloaded when the open file changes and others only when the tab is closed.

Live preview console output of the showcase plugin

Reading mode console output of the showcase plugin

Environment

  • Operating system: tested on Window and MacOS
  • Debug info:
SYSTEM INFO:
    Obsidian version: v1.1.4
    Installer version: v0.15.9
    Operating system: Darwin Kernel Version 19.6.0: Mon Aug 31 22:12:52 PDT 2020; root:xnu-6153.141.2~1/RELEASE_X86_64 19.6.0
    Login status: logged in
    Catalyst license: vip
    Insider build toggle: on
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Restricted mode: off
    Plugins installed: 1
    Plugins enabled: 1
        1: Load Unload Bug Report v1.0.0

RECOMMENDATIONS:
    Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

This issue affects both my plugin (meta-bind) and @ClareMacrae 's Tasks plugin (related issue).

The plugin to showcase this bug and the bug report was created jointly by me and Clare Macrae.

1 Like

Thanks. We’ll look into it.

3 Likes

Thanks!

We added a bullet point in the first repro, and I just noticed we forgot to update the numbering - it should be:

image

I stumbled upon the same issue and have the same question. I’m looking forward to knowing if this is something that has to be fixed. Thank you!

Thanks for the report, this will be addressed in the next release.

3 Likes

Thank you very much indeed.

I have confirmed that this is fixed in both Reading and Live Preview modes, in Insider build 1.1.10. It’s a great help!

1 Like