Shortcuts using Cmd as modifier stopped working because of broken hotkeys.json

Steps to reproduce

I don’t actually how it got to the problem, so I’ll just describe what I ran into:
I’m using Obsidian on a Mac and some time last week shortcuts using Cmd as a modifier stopped working. The only ones that were still working were Cmd-Q and Cmd-H, which I believe are implemented on the system level.
Standard shortcuts like Cmd-N to create a new note or custom ones like Cmd-Enter I created to cycle through checkbox states were not working anymore.

Troubleshooting I did

  • created a new vault → shortcuts worked as expected
  • removed all plugins and custom shortcuts from the affected vault → problem persisted (also after restarting Obsidian)
  • went into .obsidian folder of vault and moved stuff out of the way one by one to find the problem → success (see below)

Expected result

Shortcuts using Cmd as a modifier to work.

Actual result

Shortcuts using Cmd as a modifier stopped working.

Environment

What I found while troubleshooting was that the problem would go away when removing hotkeys.json from the .obsidian folder.
Looking at the file content it looked like this:

{
  "insert-template": [
    {
      "modifiers": [
        "Mod"
      ],
      "key": "T"
    }
  ],
  "theme": "system"
}%

Two things struck me:

  1. insert-template should not be there anymore, because I removed all plug-ins and deleted all custom shortcuts. Just odd, but probably not the actual problem.
  2. theme being an entry in this file, I guess that is the actual problem here

Additional information

One thing to mention: I never edited any file in .obsidian by hand, so the theme entry in the hotkeys.json must have been written there either by Obsidian itself or maybe a plugin.

this is not a problem. we preserve them.

If you figure out how this happened, open a new bug report.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.