Shortcut Keys do not work correctly on Dvorak Right-Handed Keyboard

When using Dvorak-Right Handed (DRH) keyboard layout on MacOS, some shortcut keys do not work correctly. Specifically, Cmd+P and Cmd+F do not function correctly. (The dvorak right-handed keyboard layout is a keyboard layout available by default on MacOS and other operating systems; here is an image of the layout. The numbers 5-0 on QWERTY are replaced with letters in the DRH layout. When using hotkeys in obsidian, the program recognizes some keys correctly from the DRH layout but replaces others with the QWERTY layout.

Eg. keys 5, 6, 7, 8, 9, 0, J, L, M, F, and P from the DRH are replaced with Qwerty keys, while the remaining keys use the DRH layout.

This is not a problem in windows.

Steps to reproduce

  1. Switch to the Dvorak-Right Handed keyboard layout in MacOS.
  2. Open Obsidian Settings, to the Hotkeys Tab.
  3. Select “customize command” on any shortcut key.
  4. Type “Cmd+P” (Equivalent to Cmd+9 on Qwerty)

Expected result: Obsidian shows the command as “Cmd+P”
Actual result: Obsidian shows the command as “Cmd+9” (this is wrong).

  1. Select “customize command” on any shortcut key.
  2. Type “Cmd+E” (Equivalent to Cmd+G on Qwerty)
  3. Obsidian shows the command as “Cmd+E” (this is correct).

Environment

MacOS M1 Monterey

  • Debug info:
    SYSTEM INFO:
    Obsidian version: v0.16.5
    Installer version: v0.14.15
    Operating system: Darwin Kernel Version 21.6.0: Mon Aug 22 20:19:52 PDT 2022; root:xnu-8020.140.49~2/RELEASE_ARM64_T6000 21.6.0
    Login status: logged in
    Catalyst license: supporter
    Insider build toggle: on
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 14
    Restricted mode: off
    Plugins installed: 38
    Plugins enabled: 32
    1: Calendar v1.5.10
    2: Checklist v2.2.8
    3: Convert url to preview (iframe) v0.5.0
    4: Customizable Page Header and Title Bar v4.7.2
    5: Dataview v0.5.47
    6: Excalidraw v1.7.24
    7: Fullscreen mode plugin v0.1.2
    8: Garble Text v1.2.0
    9: Hider v1.2.3
    10: Hotkey Helper v0.3.15
    11: Hotkeys++ v0.2.7
    12: Kanban v1.4.5
    13: Link indexer v1.0.0
    14: macOS Keyboard Navigation v1.1.2
    15: Obsidian Memos v1.9.7
    16: Obsidian42 - BRAT v0.6.35
    17: Recent Files v1.3.3
    18: Style Settings v0.4.12
    19: Tag Wrangler v0.5.3
    20: Templater v1.14.3
    21: Theme Design Utilities v0.19.0
    22: Supercharged Links v0.9.3
    23: Zoom v1.0.1
    24: Admonition v9.0.5
    25: CardBoard v0.5.0
    26: Zotero Integration v2.2.28
    27: Paste URL into selection v1.7.0
    28: Outliner v3.0.0
    29: Tasks v1.15.1
    30: List Callouts v1.0.6
    31: Snippet Commands v0.0.2
    32: DB Folder v2.7.1

RECOMMENDATIONS:
Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.


Additional information

from the docs:

The point being, it doesn’t matter what it shows, does it work?

It doesn’t work, though, which is the problem: I cannot use the standard hotkeys for many functions, and it’s not worth learning a whole bunch of custom hotkeys for things like “find” and “undo” just for obsidian when other apps recognise things like cmd+F on any keyboard layout.

The same issue is also on other chromium apps, which is now marked as resolved -

is there a way to apply this resolution to obsidian as well?

https://bugs.chromium.org/p/chromium/issues/detail?id=1358823#c1

Eventually we will get this patch. It’s gonna take a long time to trickle down.

I am not even sure this will fix your problem in Obsidian. We’ll see.

It seems like this patch is related to falsely doing something to keys in the number row (from a qwerty keyboard) when it’s handled as Dvorak keyboard. And even though this has been patched in chromium, it seems likely it’ll take some time to trickle down to Obsidian.

So my question for a workaround for you would be: Could you define another shortcut for the keys in the number row, so that for example the Command palette is reachable by both Cmd+P and Cmd+9? Would that even work in your current setup?

I know it’s a bit of kludge, but maybe it would do the trick until it gets solved by the underlying framework of Obsidian? And in addition, when/if solved you’d still have the default available.