SHIFT+ENTER in file opener does not create new file

Steps to reproduce

  1. CTRL+O to open file switcher
  2. SHIFT+ENTER to create new note without a title

Expected result

Expect to see an empty note. This worked until a relatively recent update.

Actual result

Nothing happens. File switcher is dismissed and previous open note remains open.


  • Operating system:
  • Debug info:
    Obsidian version: v0.13.23
    Installer version: v0.11.13
    Operating system: Windows 10 Pro 10.0.19042
    Login status: logged in
    Catalyst license: none
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: 80s Neon
    Snippets enabled: 0
    Safe mode: off
    Plugins installed: 7
    Plugins enabled: 7
    1: Theme Picker
    2: Page Heading From Links
    3: Key Promoter
    4: Journey
    5: Filename Heading Sync
    6: Dataview
    7: Calendar

Note: I’ve tried this with various themes, with all 3rd-party plugins disabled, on both a Windows and Linux machine. Behavior is always the same.

Additional information

I realize there are workarounds, but I got into the habit of using this keystroke which is shown as an option on the file switcher.

I don’t recall ever existing shift+enter to create a note without a title

@WhiteNoise - the command is listed at the bottom of the file switcher window, and it used to work as I’ve described. I’d appreciate re-opening the bug report.

As it says: “Type file to switch to or to create” → SHIFT + ENTER creates a new file if you type a file name that does not yet exist. But not without typing anything - and as far as I know that has never been the case before.

Why don’t you just use ctrl + n to create a new empty file? That works much faster anyway as compared to first open the quick switcher…

This is the point.
@toddz open a feature request for this.

I suppose it was probably an unintended fluke, but I’m quite sure it worked that way for a while. I’ll live without it. @alltagsverstand, thanks for the reminder of ctrl+n. I’d gotten in a habit and forgot that command was a thing.