Search Pane Hides Matching Notes: Frustrating User Experience

Steps to reproduce

  • Open your bookmarks.
  • Click on one bookmarked search.

Did you follow the troubleshooting guide? [Y/N]

Y

Expected result

The notes matching the search should be visible in the search pane.

Actual result

The search options pane pops out and hides the results, preventing you from seeing and clicking on your matching notes.

Environment

Desktop, MacOS


Additional information

The workaround is to click outside of the the search options pane a couple of times until it disappears, but this is inefficient and frustrating.

1 Like

You can hide this by creating a CSS snippet and putting this lines inside:

.suggestion-container.mod-search-suggestion {
    display: none !important;
}

this happens because you saved the bookmark with a search query that has space at the end. So when the query is inserted in the search box, it thinks you are about to add something else and shows you the popup.

Maybe we’ll strip the trailing space.

1 Like

thanks, that’s definitely a bug! Will be fixed in future version.

@liam thanks for the follow-up.

@WhiteNoise, FYI, it’s also happening without space. Although this takes up less room in the UI, we still have a dropdown occurring.

image

1 Like