Scroll position in reading view not correct as where caret in editing view

Steps to reproduce

  1. link two tabs - editing (source, not live mode) and reading (preview) view
  2. for example, source:
    row 1
    row 2 ![picture with big height](..)
    row 3
  3. where “row 1” is displayed at top on both reading / editing view.
  4. active / edit “row 3” in editing (source, not live mode) view, at which time “row 1” should still in range in editing view.

Expected result

reading view scroll to show "row 3".

Actual result

reading view remain stay at top to keep “row 1” displayed.
and “row 3” is out of view (for there is a picture with big height).


  • Operating system: Win10
  • Debug info: SYSTEM INFO:
    Obsidian version: v1.1.9
    Installer version: v1.1.9
    Operating system: Windows 10 Pro 10.0.19045
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Restricted mode: on


Additional information

Similar to [Syncin Edit and Preview mode not scrolling correctly - Bug graveyard - Obsidian Forum](

:x:Current sync scroll will align reading view to show top content in editing view.

:white_check_mark:I think align should be apply to user focus postion, like where mouse or caret is.
So, the focus position should be on the same horizontal line.

1 Like

Good, you should open a FR for this then.