Right-clicking selected text causes crash if text selected from bottom up

Steps to reproduce

Note in preview mode that I would like to copy and paste into an email message. Select all relevant text by clicking and dragging with the mouse, starting at the bottom and dragging to select up towards the top. Right-click expecting “copy” menu to appear.

Note that this works just fine if I select the text from the top of the note and drag down.

Expected result

Context menu with copy option to appear

Actual result

All notes and menus disappear. If translucent window turned on, i see the background of the translucent window and nothing else. If translucent window turned off, I see a completely black box where the Obsidian app should be. I can resize it, but there are no controls, and using keyboard commands (Esc, Ctrl+w, Ctrl+o) does nothing. I am forced to restart Obsidian to recover.


  • Operating system: Windows 10 64 bit
  • Obsidian version: 0.9.2

Additional information

Tried turning off custom CSS. Tried turning off translucent window. Does not make a difference.

I can’t repro. Can you post a recording?

I don’t have a good screen recorder (can you suggest one for Windows?). However, I found another subtlety with this: The note needs to be long enough such that it gets scrolled up in the window by clicking and dragging to select text. If I select text starting at the bottom and the note does not need to scroll, it behaves as expected.


Here it is, if you haven’t been able to reproduce yet.

I can reproduce

thank you

Uncaught TypeError: Cannot read property 'path' of null
    at Function.e.postProcess (app.js:1)
    at t.e.postProcess (app.js:1)
    at p (app.js:1)
    at e.onRender (app.js:1)

This is a chromium bug and I’ve filed a report for it here:

Hopefully it gets resolved quickly as the crash is really easy to reproduce and I’ve attached a crashlog. Then we’ll just have to wait until it makes it into Electron.

I’ve also filed an issue with Electron, maybe they can get an alternative fix: https://github.com/electron/electron/issues/26939

1 Like

I get this as well. Could there be an option added to just copy all of the formatted text?

This is fixed in 0.12.3. You need to download and reinstall it from the website.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.