Restarting Obsidian causing vaults to loose connection to desktops

My main setup is to run two different Obsidian vaults at once. My main vault on my main desktop (aka Desktop 1), and a test vault on my secondary desktop (aka Desktop 2). The latter desktop also has some utility tools running on it. On my secondary display I’ve got a browser usually loaded with this forum and various other tabs.

Every now and then I need to restart Obsidian, and then it always fails to open the vaults to the desktop it was connected to. So if it’s my main desktop open, they both go there, and vice versa. The window positions and size is kept as from the previous run, but not the desktop assignment.

I’m running on an older Mac Mini, on MacOS 10.14.6 Mojave, but the Obsidian version is 1.2.8, with the 1.2.8 installer. More details below.

Show debug info

Obsidian version: v1.2.8
Installer version: v1.2.8
Operating system: Darwin Kernel Version 18.7.0: Tue Jun 22 19:37:08 PDT 2021; root:xnu-4903.278.70~1/RELEASE_X86_64 18.7.0
Login status: not logged in
Insider build toggle: off
Live preview: off
Legacy editor: off
Base theme: dark
Community theme: Minimal v6.1.11
Snippets enabled: 9
Restricted mode: off
Plugins installed: 25
Plugins enabled: 18
1: Vault Changelog v0.1.0
2: Text expand v0.11.2
3: Minimal Theme Settings v6.3.1
4: Icon Shortcodes v0.9.7
5: Hider v1.2.4
6: Dangling links v0.3.0
7: Advanced Tables v0.18.1
8: Buttons v0.4.19
9: Plaintext v0.2.0
10: Templater v1.16.0
11: Style Settings v1.0.3
12: Text Snippets v0.1.2
13: Sortable v0.3.1
14: QuickAdd v0.23.0
15: Dataview v0.5.55
16: Scales and Chords v1.0.1
17: ToggleList v1.2.0
18: Custom File Explorer sorting v1.7.2

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

My question is whether this is to be considered a bug, or is it just a feature related to MacOS that I’ve got to live with? Has anybody else experienced a similar issue, and if so did you find a workaround for it?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.