Random hanging indents in checklists

Using Obsidian mobile version 1.3.1 and the current public release of the desktop app, I’m still getting weird hanging indents in check boxes like the second one in the attached image, and at least one other user on the Discord confirmed it. (SEE SCREENSHOT)

The issue appears to occur primarily or exclusively in Live Preview, though I don’t use Source Mode enough to say for sure. (Please comment below if you’ve experienced it in Source or Reading modes.)

Steps to reproduce

They happen pretty randomly, and although using Minimal’s alternate check boxes particularly seems to trigger them, I also get them when not using alternate checkboxes. (Kepano says it’s an Obsidian bug, not an issue with the theme.)

Expected and actual result

Indents should look like the ones in the top and bottom checklist items in the attached screenshot, NOT like the middle one.


The issue occurs in both macOS and iOS.

(NOTE: I removed a reply about this from another bug report after realizing that this is a separate issue.)

Additional information

1 Like

Does this happen with default theme/no snippets/no plugins?

Have you updated the theme lately?

I was using Minimal too, and had similar problems (on desktop) with inconsistent list alignment. And after I updated the theme it fixed it. There were some theme changes in the 0.15 releases.

Now in 0.16, there are major theme changes. I’m not sure about mobile. But I know Minimal is listed as legacy, and I’ve personally just switched to the default theme for now. There may be breaking compatibility issues for a while.

Yes, it also happens with the default theme and Restricted Mode turned on to disable all plugins—in both the desktop (macOS) and mobile (iOS) apps. (see screenshot)

This is a long-running issue spanning multiple updates, but I’m currently running desktop version v0.15.9 (Installer version: v0.15.6) and mobile version 1.3.1.

As I said in my bug report above, @kepano replied to me on the Discord when I reported it there (#mimimal) first that this is a bug in core Obsidian, not Minimal.

I’m running the latest version of Minimal on desktop version v0.15.9 (Installer version: v0.15.6) and mobile version 1.3.1, BUT it also happens in the default theme with restricted mode turned on. As I said, @kepano replied to me on the Discord when I reported it there (#mimimal) first that this is a bug in core Obsidian, not Minimal.

There are improvements coming for this in 0.16.3

1 Like

Thanks for letting me know! I’m still using 0.15.9, so I’ll just ignore the issue until I update to 0.16.x. Should I assume the same for mobile—that the fix won’t come until the next version arrives with the new default theme?


1 Like

Thanks, but NomarCub’s issue appears to be the opposite of mine: their second and subsequent lines aren’t indented enough, and mine are indented too much.

Also, it looks like you marked their issue as solved, but I don’t see the solution. It probably doesn’t matter, though, as Kepano says above that the issue will be fixed by the 0.16.x public release.

Did you read this?

I guess what was confusing was that the bug was marked as solved, which indicates that there’s a solution already available, but the message says it won’t be solved until a future release.

This should be fixed too on mobile at this point.
@Synchronicity Can you confim?

Yes, it’s definitely fixed. A big thank you to you and the whole team!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.