Publish: Graph not showing on custom domain with Safari

For anyone else using Publish at the minute, does your graph in the top right still view? I have the frame showing but not the actual nodes / graph… I’ve checked settings and graph is enabled. Any help would be greatly appreciated.

Is this happening on Safari only? I think I heard about a similar bug.

Yeah, I’ve only got Safari installed. I guess so :slight_smile:

My publish seems fine at the moment

https://publish.obsidian.md/santi

@scott1 what’s your publish link, I can have a look here in firefox and other browsers if you like, just to see if your problem is only on safari

notes.st.im -> I think I found the problem, it’s the custom domain. If I go to the original Obsidian Publish URL the graph works.

try to clear the cache

This URL seems to work on firefox alright, the graph seems to show correctly

I’m still experiencing this on the custom URL but not on the Obsidian Publish link — any ideas?

It works for me.
Did you try clearing the cache? Did you try open the page on ingnito window?
Do you use some custom css?

Hi WhiteNoise, thanks so much for the reply. Yeah, just tried incognito, clearing cache, and no custom css — still doesn’t show in Safari for the custom URL link, but does show for the Obsidian Publish link.

Also, I should note that the Obsidian Publish link is much faster to reflect changes than the custom URL link.

what happens if you clear the cache and open first notes.st.im ?

That didn’t work either. Attaching console output, which may help triage. The error does not display for the Obsidian Publish (non-custom) URL.

thanks, we’ll look into it. It’s a safari only problem

will be fixed

I have pushed a fix - can someone with Safari let me know if that helps?

Fixed! Thanks so much.