I have just updated to 1.4.5 with the new properties view.
Not wanting this cluttering the top of pages in Read mode, I went into the options to turn it off. Not possible. Whether “On” or “Off”, the properties remain visible even after restarting Obsidian.
I am running diverse vaults on diverse themes but even the default theme is showing this behaviour

Properties need some more tweaks, until then I prefer to keep Obsidians previous version.

Maybe of help

1 Like

When you submit a bug report, please make sure to read Troubleshooting Guide and adhere to the bug report template.

Moved to the help section.

It’s a bit confusing, but the thing called “Properties view” under core plugins doesn’t refer to the properties UI itself, but rather to a separate plugin that can show properties in a separate pane (similar to how the “Tags view” core plugin shows a list of all tags in a separate pane). This pane can show either the properties for the current note, or the properties across all notes in your vault.

To shut off the properties UI itself, go to Settings → Editor → Properties in document and select the “Source” option. This turns off the properties UI and displays your YAML frontmatter as plain text in editor mode (though it will still show the properties UI in reading mode).

Alternatively, you can select the “Hidden” option to hide properties / frontmatter from both the editor and reader view.

1 Like

How can you only show the properties of the current file in the “properties view” pane?
Sorry for the the silly question, but can’t figure it out.

1 Like

You’ve to activate a core plugin in Obsidians settings.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.