Properties not rendering correctly when using properties for breadcrumbs navigation

Steps to reproduce

  1. Open sandbox vault
  2. Add a property “parent” with type “list”.
  3. In “Vault is just a local folder”, add property parent: “[[Plugins make Obsidian special for you]]”
  4. In “Plugins make Obsidian special for you”, add property parent: “[[Start Here]]”.
  5. Use properties overview on top of file to browse from “Vault is just a local folder” → “Plugins make Obsidian special for you” → “Start here”.

Did you follow the troubleshooting guide? [Y/N]

Reproducible in sandbox vault.

Expected result

You can navigate through all three files.

Actual result

After switching from “Vault is just a local folder” → “Plugins make Obsidian special for you”, the wrong properties are displayed (it seems to render the parent property from the previous file.)

Environment

SYSTEM INFO:
Obsidian version: v1.4.16
Installer version: v1.4.13
Operating system: Darwin Kernel Version 23.1.0: Mon Oct 9 21:27:24 PDT 2023; root:xnu-10002.41.9~6/RELEASE_ARM64_T6000 23.1.0
Login status: logged in
Catalyst license: supporter
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on

RECOMMENDATIONS:
none

(I can also reproduce it on a second device with Windows 11)


Additional information

  • If you close and reopen the note, the correct properties are rendered. It only shows wrong property if directly navigated from another file which has the same property.
  • The source view (and/or opening it outside of Obsidian) won’t change so it’s a rendering bug in live view.
  • It only bugs out if the property is type “list” (it seems to work with “text”).
  • Here’s a video: Dropbox - CleanShot 2023-10-27 at 16.16.59.mp4 - Simplify your life

Thanks, this issue has been identified and will be fixed for the next release.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.