Properties in excluded folders are counted (and they shoudn't)

Steps to reproduce

With a large number of notes already created with numerous properties, open the properties panel.
Click on a porperties with one note lilke this to look for notes where it can be:

Did you follow the troubleshooting guide? [Y/N]

This can’t really be reproduced with a sandbox because it requires a large number of notes and properties, but it’s still the case without snippets, themes and plugins.

Expected result

It should display the result of a note containing this property, in the search view.

Actual result

It there actually 0 note with this properties.

And even with a simple search, nothing is displayed.


Obsidian version: v1.4.5
Installer version: v1.4.5
Operating system: Windows 10 Pro 10.0.22621
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: light
Community theme: none
Snippets enabled: none
Restricted mode: on

Additional information

When I click on the properties, the Unassign type option is grayed out and I can’t select it.

These bugs occur with many properties. I’ve closed and reopened obsidian several times.

1 Like

Can you zip your vault, upload it somewhere and dm me the link?

Also, are you using excluded folders?

Ho, sorry. I had forgotten that I actually had exluded files. That’s where it came from.
Thanks for you response.

But, In my logic, excluded folder properties shouldn’t be displayed. I think there should be a way to exclude them from there too.

Do I have to post a feature request?

renamed this bug report.

related to: Tags in excluded files should not appear in the tag list

A solution to the properties issue could be to add two items in settings:

  1. Exclude properties from excluded folders
  2. Exclude list of properties (useful for removing plugin added properties, such as excalidraw for ex)
1 Like

will be fixed 1.4.7

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.