Properties in document ignores Source

Steps to reproduce

  1. Enable Properties plugin
  2. Add property to a file (e.g. an alias)
  3. Pick “Source” as the Properties in document setting
  4. Open the same file in Reading mode

Did you follow the troubleshooting guide? [Y/N]

Y

Expected result

For properties to only be displayed in the Source mode

Actual result

Properties are still shown in the Reading mode. In fact, behaviour is identical to “Visible” setting

Environment

SYSTEM INFO:
	Obsidian version: v1.5.12
	Installer version: v1.5.12
	Operating system: #1 SMP PREEMPT_DYNAMIC Wed, 17 Apr 2024 10:11:09 +0000 6.6.28-1-lts
	Login status: not logged in
	Insider build toggle: off
	Live preview: off
	Base theme: adapt to system
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on

RECOMMENDATIONS:
	none

Additional information

I don’t understand you. Sorry.

Properties are not shown in reading view only if you select hidden.

This setting determines how properties are displayed in the editor.

Ah, i see, my bad. I don’t use Live Preview so i didn’t notice the difference between the Source and Visible, and assumed the setting affects both editing and reading