Properties: Date format not following system settings

I’m having the same problem, when I use English, on windows 11. If I change system language to Swedish it works ok.
Swedish System Language with Swedish Region Settings show correctly:
image

But with English System language and Swedish region setting it show “10/14/2023 08:05”

The regional settings/format should stay fixed (even if you switch languages) and can be customized the way you want.

To check your settings are correct, you can look at how the date is displayed on window taskbar. It should look the way you set up “short date” in regional format. After that, obsidian (and chrome) will follow (a restart of Obsidian might be needed).

I’m having the same problem. I use my system (Windows 10) in English, but my localization is in Brazilian Portuguese. Obsidian does not recognize the Windows localization settings and serves me the dates in en-US format.

The screenshots below show my localization settings and how Obsidian shows the dates. Also, other software like Office and Firefox renders dates correctly.

Screenshot 2023-10-19 092622

Screenshot 2023-10-19 092531

How does the windows clock on the taskbar look like?

Just replying to link this related Feature Request for future reference: Properties: let the user customize the way Dates/Times are displayed (independently from OS) - #52 by barabasz

1 Like

Hi. Is number display format in number properties (thousand separator and decimal separator) determined by OS settings or something different?

Sorry for the late answer. The windows clock shows the date in the correct format.

Screenshot 2023-10-28 095557

@ImmaterialAardvark ok, now post a screenshot of the date in Obsidian, both in the properties UI and in source mode.

Iʼm here on Linux (Kubuntu derivate “Tuxedo OS”) and set the OS date explicitely to German style and it does not adjust in view mode. The format in source mode is 2023-10-29:

Operating System: TUXEDO OS 2
KDE Plasma Version: 5.27.8
KDE Frameworks Version: 5.111.0
Qt Version: 5.15.11
Kernel Version: 6.5.0-10006-tuxedo (64-bit)
Graphics Platform: X11

I already restarted the OS multiple times. I would expect Obsidian to take either the system format or a custom style as suggested in Properties: let the user customize the way Dates/Times are displayed (independently from OS) - #52 by barabasz

Thanks!

Hi @WhiteNoise, sorry for the late reponse again, but I do a lot of field work, and don’t check this forum to often as I should.

Here are the screenshots:

In properties UI:

In source mode:
Screenshot 2023-10-30 223606

If you open chrome and go on this page. How does the date input look like?

In Vivaldi, the date shows in en-US format (screenshot bellow).

Screenshot 2023-10-31 193036

Ok than this is either a Windows bug or a chromium bug.

Maybe. Vivaldi settings shows configuration almost correctly, but it shows the wrong date only in forms in sites.

Screenshot 2023-10-31 211158

With Linux it looks like this. So, is it a Chromium bug? My language is English whereas my date format is German. Perhaps Chromium uses the standard date format for the selected language instead of the date format independent of the standard format of the selected language?

For Linux the problem is figuring out where chrome is reading the locale information. You are setting something for kde, but is it for kde or is it system wise?

Is there a way to find that out or wouldn’t that help with fixing this issue?

Just an update, after formatting my PC because of unrelated problems, in Windows 11, my Properties now work as intended. I have no idea why, though.

Yikes! This is awful. need to downgrade obsidian for the first time.

Hello. Got similar issue on Windows 11.
I would like to see YYYY-MM-DD, but I dee mm/dd/yyyy.

  1. Obsidian shows mm/dd/yyyy
  2. Windows taskbar shows YYYY-MM-DD
  3. Short dare windows format is YYYY-MM-DD
  4. Chrome date input shows mm/dd/yyyy

Any workarounds for this?

Screenshot: