Properties are added as markdown

What I’m trying to do

I seem to have an issue with using the templates, my process is:

  1. create a new note with a title that includes one of the note prefixes
  2. Insert meta, to automatically add the relevant template.

The problem I am having is that the properties content of the template is being added as standard markdown rather than front matter. This is happening, I think, because the created date is being added before the template properties.

Am I creating notes incorrectly or might there be an issue with how I have configured Obsidian perhaps?

Things I have tried

I noticed that after opening my template that the created date had been added to the template, i removed this frontmatter outside of obsidian using VS Code but the fromt matter for the date is still being added.

I should add that i am using Bryan Jenks’ template vault

Can you share the note template?

Sure, this is a screen shot from my mobile, but i am running this from a widows laptop when i get the issue

That file is meant to be created with templater: GitHub - SilentVoid13/Templater: A template plugin for obsidian

You can tell because of the <% %> around everything.

That’s why the properties are being added as markdown.

You have 2 options from here as this doesn’t seem to use any templater scripts… you can convert the file to work with basic templates or use templater.

---
tags: 
 - stuff
publish: true 
aliases:
---

That’s all that is in the template are the properties.

Publish: true looks to be for obsidian publish. If you aren’t using that, you probably don’t need this property.

Thanks for the reply @AngelsOfDarkness

I am already using Templater (and do not have the core Templates plugin activated).

I have tried some fruther tests.

  • I created a fresh new version of Bryan’s template (here: Template_Vault - Google Drive)
  • Then opened the Meta file in the Templates > Inputs folder
  • I noted that this file has no frontmatter/yaml
  • if I create a new note, use one of the template symbols (e.g. @ for the Person template) then template is created fine.

The issue has occured where I have modified the Meta.md file. What has happened is the created and updated frontmatter has now been added to the template. If I could either these things the frontmatter would get created as expected:

  1. remove the frontmatter from the Meta.md file (this doesn’t work because as soon as I delete the created/updated frontmatter it is added back again).
  2. alternatively if I could ignore any frontmatter in my template files that would work.

I’ve been digging around trying to find a solution to either of these things but to no avail.

I keep wondering whether this might be a configuration setting somewhere? e.g. “do not add frontmatter to template files” …but alas I have not been able to resolve this!

Any help or advice appreciated!

I’ve figured this out! After days of trying :slight_smile:

I realised I had the “Update time on edit” plugin installed and this was causing the issue. I’ve now set the following options to be the “Templates” folder and it seems to work!

  • “Folder to exclude of all updates” and
  • “Folders(s) to exclude for updating the created property”

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.