Problems creating and switching between notes

We strongly recommend you to search the forum with possible keywords before submitting a new bug report. Please also try your repro steps with community plugins and custom CSS disabled and see if it’s still reproducible. Alternatively, you can use the Sandbox vault (lower left corner ? → Open Sandbox vault).

If it’s an issue with third-party plugins or themes, try contacting the author for help.

Mobile-specific bug reports should be filed here: https://forum.obsidian.md/c/mobile/18

Once you’ve done the above, delete everything above this line.

Steps to reproduce

  1. Click on note title to open it
  2. Search for specified term

Expected result

Actual result

Things tried:

Relaunching Obsidian
Rebooting Mac and relaunching Obsidian
Launching Obsidian in Safe mode

Environment

  • Operating system:

MacOS Ventura 13.0

  • Debug info:
    SYSTEM INFO:
    Obsidian version: v1.0.3
    Installer version: v1.0.3
    Operating system: Darwin Kernel Version 22.1.0: Sun Oct 9 20:14:30 PDT 2022; root:xnu-8792.41.9~2/RELEASE_ARM64_T8103 22.1.0
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: adapt to system
    Community theme: Things
    Snippets enabled: 4
    Restricted mode: off
    Plugins installed: 44
    Plugins enabled: 26
    1: Day Planner v0.5.8
    2: Dataview v0.5.47
    3: Better Word Count v0.8.1
    4: Calendar v1.5.10
    5: Kanban v1.4.6
    6: Note Refactor v1.7.1
    7: Periodic Notes v0.0.17
    8: Review v1.6.4
    9: Tag Wrangler v0.5.4
    10: Templater v1.14.3
    11: css snippets v0.1.2
    12: Banners v1.3.3
    13: Outliner v4.1.0
    14: Natural Language Dates v0.6.1
    15: Hotkeys for specific files v1.2.0
    16: QuickShare v1.0.1
    17: Show Current File Path v0.5.2
    18: QuickAdd v0.5.5
    19: DB Folder v2.7.4
    20: Icon Folder v1.3.5
    21: Typewriter Scroll v0.2.2
    22: Multi-Column Markdown v0.7.3
    23: Tasks v1.18.1
    24: Homepage v2.4.1
    25: Auto Note Mover v1.2.0
    26: Divide & Conquer v1.0.0

RECOMMENDATIONS:
Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.


Additional information

post a screen recording of this happening in the sandbox vault

Done that - are you able to see it though since changes there aren’t saved?

The screen recording shows me launching Obsidian, clicking on a new note, the title of which appears at the top of the existing note. After 3.10, the content of the new note appears.

I then do a search on a term I know is in the title of a note. A few results are returned, more were returned but after 10 minutes the search is still going on.

Where’s the screen recording?

Not sure how to get it to you. Don’t know how to add it to sandbox vault as you requested.

Upload the screen recording somewhere and attach a link here.

Make the sure the screen recording is of this bug happening in the sandbox vault (or no themes/no third party plugins).

Also, make sure you vault is stored locally on you device (no google drive options to download the files on demand).

I am gonna move this to help, because I don’t think there’s bug here.