Problem with an empty object as frontmatter content

Steps to reproduce

When deleting all properties of a note programmatically, I intended to leave an empty object, to indicate that this note needs some properties but is left empty temporarily. Then the frontmatter in the source mode would look like


Did you follow the troubleshooting guide? [Y]

Expected result

I though there would be a UI with no property line but only an Add property button in both reading and live preview modes.

Actual result

Nothing would shown up under reading / live preview mode. Neither Properties UI, nor error hint (invalid frontmatter etc.)

Either adding an empty properties UI, or providing error hint on empty object would be quite helpful. Currently, if users are handling notes with these “occupied” frontmatters in live preview mode, they won’t be able to create properties by typing ---, as it will be recognized as a separator.


Obsidian version: v1.4.16
Installer version: v1.4.13
Operating system: Windows 10 Home China 10.0.19045
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 1
Plugins enabled: 1
1: Projects v1.17.0

Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

I don’t know if this will be considered a bug or not, but you could try this for now:


Thanks for the response! Unfortunately this won’t work, the front matter you provide will result in a field named as {}.

I’ll wait for the official feedback for a better consistency on handling empty properties anyway.

Same behavior on empty yaml content



This is not a bug, it is currently intentional. Please open a FR.

Thanks for the clarification, the correponding FR is here.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.