Problem opening Zotero links

Hi!. I am also using Linux and I have a problem. Links to Zotero in format [1] (zotero: // select / items / 1_QZBJXD8N) cannot be opened from Obsidian. Nothing happens after clicking on it. From a text editor (LibreOffice writer) or a browser, the link works. Could you help me what I need to configure?

PS: all steps from instruction I have done - install translator and chose it in settings


How are you formatting your link? It should use markdown formatting [like this](zotero://....)

Exactly as in your example. Here is an example link
[Lapteva. 2019. *Domestic Engineering - Industry 4.0 Technology Transition Problems*](zotero://select/items/0_MG3KUW6P)

Are you trying to click on it from edit or preview mode? In preview mode clicking should be enough, but in edit mode you need to do Ctrl + Click

Yes. I tried different options Cntrl+Click, Shift+Click, but nothing happens, and nothing notification about any errors. At first, I suggested its problem with the link. I copy link in parentheses zotero://select/items/0_MG3KUW6P and passed to another programs. From browser and LibreOffice its works.

Just thought about this… the Zotero URI needs to be configured for it to be recognized, does it work from your browser? If you installed Zotero from the deb file in zotero-deb this would take care of it. Otherwise you have to set it up manually, e.g. as suggested in this SO question

Yes, link work from browser correct - open zotero and chose item. Zotero have been installed from .deb package

Thank you @argentum. This suggestion to install zotero-deb solved my issue. I had installed the tarball from the Zotero site, and was able to open zotero URI from other apps, but not from Obsidian. Not sure why this would be the case. In any event, very much appreciate your help.

1 Like

Tried using the link in another similar program - Zettlr, everything works well. Most likely a problem in Obsidian

I moved this to its own thread in #help.

@alex_m I suspect this is a problem with your setup, not within Obsidian. Could you please share the following?

  • The output of xdg-mime query default x-scheme-handler/zotero
  • The output of xdg-settings get default-url-scheme-handler zotero
  • In which section does Zotero appear in your ~/.config/mimeapp.list
  • A GIF trying to open the note with the link

Moving this to #resolved-help. Let me know if you still have issues!

Hi ! I’ve just transitioned to Linux from Windows and I’m trying to re-implement my workflow zotero->zotfile->mdnotes->obsidian. Unfortunately, I have the same problem as described by @alex_m above : nothing happens in Obsidian when i click on a link to Zotero in format [...](zotero://...). It does work though when I use the same link in the browser or LibreOffice Writer.

I work with ubuntu 20.04, I’ve downloaded Zotero from the deb file and Obsidian in the flatpak format.

As suggested by @argentum , it might be a setup problem. The outputs of xdg-mime query default x-scheme-handler/zotero and xdg-settings get default-url-scheme-handler zotero are both zotero.desktop and Zotero appears in the [Default Applications] section of ~/.config/mimeapp.list.

Any help welcome, thanks ! :wink:

Nevermind, i solved my issue. I found an old zotero.desktop file from a previous installation that was probably messing things up. I deleted it and everything works like a charm now !