Possible bug in IPadOS 15 Public Beta 3 / Mobile Obsidian - “-“ and “=” keys don’t work

Steps to reproduce

As far as I can tell, it appears randomly on

  • IPad Pro 12,9” + Magic Keyboard.
  • Obsidian 1.03
  • iPad OS 15 Public Beta 3

But once it appears, I need to reboot my iPad

Expected result

The upper right hand keys (top row, two keys to the left of the backspace key) - i.e the “-“ and “=“ keys should type “-“ and “=“ respectively

Actual result

Nothing happens in Obsidian (no output) - even though they work perfectly well in Apple Notes, or any text based application I’ve tried ….

Environment

  • Operating system:
    IPad OS 15 Public Beta 3
  • Obsidian version:

Additional information

does it happen if you have no third party plugins enabled?

Sorry, should’ve been more explicit: yes, I tried it with NO ⅓ party plugins and NO ⅓ party themes …

does it happen in ipados non beta?

Unfortunately I can’t tell as I have one iPad and I just started to run obsidian mobile on it. I guess we’ll just have to see if it goes away in future betas or the final release.