Plugin installer/updater doesn’t care about minimum Obsidian version required by plugin

Steps to reproduce

Try installing the Dictionary plugin v2.11.0 when using Obsidian 0.12.10 (non-insider build). The plugin requires a minimum Obsidian version of 0.12.11.

Expected result

Some kind of error message, or—even better—let me install the latest plugin version that was allowed for my Obsidian version.

Actual result

Installs plugin, which then doesn’t function (using the new 0.12.11 request API).


  • Operating system: Linux Mint 20.2/Cinnamon DE
  • Obsidian version: 0.12.10 (Installer 0.12.10, Linux AppImage)

Additional information

Sorry for the noise, will try again. The plugin had accidentally set

"minAppVersion": "0.12.0",

it seems.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.