Pipe character interpreted as "new column" when used to create alias within [[link|linkalias]] in a table

Steps to reproduce

  1. create new file
  2. in edit mode, paste the following:
    col1 | col2
  3. Open preview mode.

Expected result

col1 col2

Actual result

col1 col2
[[link link_alias]]


  • Operating system: Windows 10 64 bit
  • Obsidian version: v0.11.5

Additional information

screen from edit:
screen from preview:

1 Like

I’ve encountered this too. I’ve been using the \ escape character before the | and that has solved the issue for me. It would be nice not to have to worry about that though, agreed.


This has been reported before. Please search before posting.

Good to know. I’m surprised that worked myself.

The contexts are different. The context of [Parser Problems in Tables: Math\Latex, Inline code and separator |] is a table and latex code block. The context of this post are internal links and a table. The solution to both issues may be the same but I don’t have the expertise to decide that.

ooh you are right. This is covered in the included help vault.


1 Like