Pinned Tabs Not Staying Pinned

What I’m trying to do

I’ve noticed that besides the first tab I pinned, which does stay open through closing/opening the app, any additional pins do not appear to stick.

Things I have tried

Searched through “pinned” in forums, have looked through settings to see if there was anything that jumped out.

1 Like

Do you use Obsidian on multiple devices? Do you keep your vault in a cloud tool, like iCloud or Dropbox? etc.

If you do, there is a chance your workspace settings files have conflicted copies.

Navigate to /YourVault/.obsidian and check for “conflicted copy” or extra numbers on the ends of your workspace.json or workspaces.json files.

This isn’t specific to pinned tabs. If this setting gets conflicted, the entire layout can have trouble saving.

I use Obsidian Sync for multiple device access - My vaults also are backed up with OneDrive for work and Google Drive for personal, but that is only for backup purposes, vaults are being opened via “Open vault from Obsidian Sync”.

Regardless, no I do not see more than a single workspace.json, and none with numbers appended.


To clarify, do you mean you are one-way copying your vault to Google Drive and OneDrive?

Because otherwise if you are editing/syncing your Obsidian Synced vault in a live cloud folder, even if the files are not visibly conflicted, they might be overwriting each other.

I would triple check you don’t have any mixing sync tools. And if you are certain you don’t, I guess the next thing to check is the standard debugging steps:

And perhaps post your “Show Debug Info” to see if there are any plugins people recognize that could be causing the trouble.

Hey rig! Yes, my vaults are only being one-way copied to both of those locations. The vault in particular that I’m troubleshooting is only on OneDrive (besides Obsidian Sync), and that particular OneDrive account is only signed on a single device. Fairly confident it’s a non-factor for this scenario, but if I’m not getting anywhere otherwise I’m certainly fine temporarily sticking it in a regular folder. :slight_smile:

Debug info:
Obsidian version: v1.3.7
Installer version: v1.1.16
Operating system: Windows 10 Pro 10.0.22621
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: SynthWave v0.0.0
Snippets enabled: 0
Restricted mode: off
Plugins installed: 4
Plugins enabled: 3
1: Auto Note Mover v1.2.0
2: Doubleshift v2.2.1
3: Homepage v2.8.1

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Might not help with this issue but Obsidian 1.3.7 needs installer 1.1.9 or higher for full functionality.

I’ll definitely try that as well!

1 Like

1.1.9 installer does not appear to have helped, but was worth a shot! :slight_smile:

1 Like

Well no it isn’t on a single device. It’s a cloud tool. So it’s uploading/downloading to whatever server it syncs to. I might be wrong, but I would confidently bet that this is the source of your problem. Don’t cross the streams!

Moved it to a local folder, problem persists. So we can rule out OneDrive.

1 Like

Watch the Sync log for activity on workspace.json and/or workspace-mobile.json. (The log can be viewed by clicking/tapping the Sync status icon.) That may give you a clue as to what’s happening.


Another thing to try, if you’re up to it, is to move or rename that .obsidian/workspace.json (desktop) file with Obsidian closed. This will reset your workspace to the default layout when you re-open the vault, so you’ll have to set up your windows and re-pin what you’d like.

If you close & open the vault again and things are as they should be, it was something about that workspace.json file that that was messed up.

If it’s not as you left it, then I guess it’s something else.

Just as a quick test, I arranged the workspace and pinned a bunch of tabs in a test vault. Everything comes back the same with multiple closings & openings of the vault. (Obsidian v1.4.4)


No luck! But ty for the suggestion! :slight_smile:

Realized this morning I’d foolishly never tried uninstalling/reinstalling Obsidian. Did so, made sure no files stuck around after doing so, then reinstalled. Pinned tabs still not staying pinned, and my one tab that was staying pinned doesn’t stick now either. :frowning: Not a major issue since other pins weren’t sticking, just wanted to add an additional troubleshooting step performed!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.