Phone - Hide frontmatter in core slide(show)

I want to hide the yaml header / frontmatter in slides ( core plugin) on my phone, so i wrote following rule

.is-mobile .reveal .slides .frontmatter-container {
  display: none !important;

My rule is simple and works without is-mobile on desktop.
Not so on mobile, where i tried to add !important, again no results. As if the phone version of Obsidian wouldn’t know what a frontmatter container is but i highly doubt that. What’s missing?

Some ideas what i should change or try?

I don’t use Slides so I can’t confirm the selectors, but could you give this a try (adding your Slides-specific selectors after .is-mobile, as needed)?

.is-mobile .cm-line:has( {
    display: none !important;

Good idea :ok_hand:I added your code to my theme ( coming soon ) deactivated community plugins, but the frontmatter is still visible. Same, with your code loaded as a snippet - also, there is no difference with the selector options is-mobile and is-phone added. Hmm

To go a step further (default theme, plugins off, just with the test snippet on) i activated frontmatter in preferences>editor>show frontmatter and now obsidian shows me a double frontmatter on the first page of my slides :astonished:
(See attachment)
Basically, we both target the wrong selector, but I’ve no idea what rule i should write, if the selectors .reveal .slides can’t talk to the frontmatter in slides.
Also prefixing your rule with .reveal .slides does nothing
Btw, the brownish top bar is from my theme but didn’t go away after effectively deactivating my theme (checked)