PDFs not loading

Hello All,

I am new enough to Obsidian to be dangerous. I am trying to embed PDFs but like other posters - no cigar!

There are many who say to reinstall Obsidian (I am on insider build v1.1.6)

My questions:

Does each update keep intact the error, retaining the same bug each time I update?

Is a full / clean reinstall the only solution?

What is causing this error under the hood?

Many thanks,


Things I have tried

What I’m trying to do

You’ve said a lot of things, but none of it was details about the problem.

Can you show a screenshot of how it doesn’t work? What operating system? Post your “Show debug info”.

Hello @rigmarole

Thank you for your reply.
After drag drop of pdf into this page I get the attached…
OS is Mac 12.2.1. Not sure how to access: “Show debug info”
Many thanks,


Type Cmd-P, and you get the command palette. Then type “Show debug info” and run that command. You can then copy paste that here.

Many thanks, @rigmarole,

Here is the debug info:

Obsidian version: v1.1.6
Installer version: v0.14.5
Operating system: Darwin Kernel Version 21.3.0: Wed Jan 5 21:37:58 PST 2022; root:xnu-8019.80.24~20/RELEASE_ARM64_T8101 21.3.0
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: LYT Mode v1.5.0
Snippets enabled: 0
Restricted mode: off
Plugins installed: 2
Plugins enabled: 2
1: Calendar v1.5.10
2: Pandoc Plugin v0.2.5

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

With thanks,


Download and reinstall Obsidian from the website. Your installer is very out of date, past the point where it can fully auto-update. This might solve the problem.

You will not lose your vault or any of your notes, or settings. This just reinstalls the app with the latest CodeMirror components. (It never hurts to backup your vault to be safe.)

Sometimes the browser or local default PDF viewer app could cause such a problem, it think. After reinstalling Obsidian like rigmarole told you, with new installer, try to open the same PDF in you fav browser - is it opening good? If not - try to update PDF viewer.

I’ve seen such kind of error once in a while when the file was protected, btw.

Dear @rigmarole and @max_cherepitsa

Thank you both for sticking with me on this.
The reinstall has the pdfs rendering beautifully. This was an area of Obsidian that I could never nut out and now it works so smoothly.
I appreciate your help and I am further enamoured with the Obsidian project.

With gratitude and kind regards,



This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.