Pasting Images don't work anymore, but screenshots on clipboard does

From the new version released this summer (I’m now running version 0.15.9) I can’t visualise anymore pasted images.
I am running the desktop version on a macOS Monterey 12.4

Steps to reproduce

When I take a screenshot with Cmd+Ctrl+Shift+4, it copy the image to the clipboard and when I paste it into a note the image appear (so no problem).

The problem is when I try to copy images from other sources (in particular plots from PyCharm). When I try to paste it, the image is not properly shown.

Funny thing is, if I save the picture explicitly on the desktop, then copy-paste it from that file, it works.

Expected result

image

Actual result

Environment

  • Operating system: macOS Monterey 12.4
  • Debug info: SYSTEM INFO:
    Obsidian version: v0.15.9
    Installer version: v0.15.9
    Operating system: Darwin Kernel Version 21.5.0: Tue Apr 26 21:08:22 PDT 2022; root:xnu-8020.121.3~4/RELEASE_X86_64 21.5.0
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Restricted mode: off
    Plugins installed: 1
    Plugins enabled: 1
    1: Citations v0.4.4

RECOMMENDATIONS:
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.


Additional information

I did not have this issue with the previous version of Obsidian.

Then maybe the problem is pycharm?

What happens if you copy an image from chrome or safari?

Actually you are right, when copying an image from safari then the image is correctly pasted on Obsidian…

But I’m sure that this problem manifested only when I upgraded obsidian… It would be very valuable for me to be able to copy-paste directly the plot instead of taking a screenshots… any idea of what could be done?