Pasted Screenshots images fail to display

i tried many screenshot ways, but failed to have an image inside obsidian.

Editor: image

Output: image

Are you using a photo that is held on the web? works well.

I think I am having troubles with almost every kind:

  • Screenshots
  • PNG that I moved into vault. Opening in Windows Explorer, while in Obsidian it is not able to embed.
  • I didn’t try online images with links, but drag drop had the same error.

Still not able to paste or view any new image I add to the system :frowning:
It’s a stand still for me.

I don’t know if this is the same issue, but I just noticed a problem with pasted images this morning. If you look at the PNG file signature spec PNG Spec you will see the following:

and if you look at the signature of a pasted image saved by a previous version of Obsidian you will find this signature:


A pasted image saved by a the current version of Obsidian (v0.10.1) has the following signature:


The ef bf bd at the start of the file in the above image is the UTF-8 encoding of the Unicode character U+FFFD REPLACEMENT CHARACTER.

codepoint character listing

I’m still trying to figure out if this is something to do with a system level update or Obsidian itself. I’m running Manjaro KDE with the latest updates.

A reference to a similar problem:

I am "whatever this is " illiterate, I simply see non-displayable images, both in system explorer and the Obsidian. Not its somewhat fixed. I don’t know why it was happening.

I put that information more for the devs in case it turns out to be a problem with Obsidian itself and not something I’m doing. What I was saying is that when you paste an image into a note it looks like when the image is saved as part of the note the image file is corrupted for some reason so it can not be displayed in the note.

The problem was with a Plugin I think. I tried zeroing it out, but it was a lot of work. To find it out, I needed to turn off plug-ins then restart app, and then try again.

I will try to see which one of them was causing the problem.

Another data point to add… If I have Obsidian running and manually copy a PNG image to my attachments directory, that PNG is immediately corrupted. If I close Obsidian and manually copy the image, then it is intact. It almost seems like Obsidian’s file watcher functionality is corrupting the PNG. Is there code somewhere parsing files looking for the signatures in image files?

Similar thing I observed as well.
Try to see if there’s a Plugin that is creating a problem for you. In safe mode I had no problems with the images, also a few plugins that I tried worked flawlessly. Try to use your setup in safe mode.

Excellent idea… doing that now…

EDIT: turing on safe mode has no effect, images still being corrupted… hrrmm

Safe mode and restart the app?

You’re right… forgot to restart d’oh…

So one of the 3rd party plugins misbehaving?

Yeah. I tried last night, but I was sleepy and couldn’t concentrate. I will see which one it was.

Can you share your list of add-ons?

You wouldn’t happen to be using:

Disabling that fixed the problem for me…

So it got an update recently. Like yesterday! That was what causing the problems.

Can you raise an issue there on github? Tag this page alongside. I am not on my system rn.

This was the last commit

Seems suspect…

I’ll create an issue… on GH

Well it looks like SilentVoid13 beat us to the punch… latest update fixed it v0.5.4

The commit above fixes the issue… Thanks for the debugging effort :smile: