Over 2,000+ duplicates of the "workspace" file under the ".obsidian" folder

hello, everyone

(title) the issue I’m having is not just there are way too many “workspace” duplicates, the Obsidian app doesn’t remember my workspace layout on startup, meaning that it shows the blank default layout on startup, so I have to run the workspace core plugin to load my preset layout every time I kill the app and relaunch it

so there are 2 issues, and I think they are related and possibly have the same root cause

I’m trying to identify what generates all these duplicates, so far it seems to be an iCloud glitch (iCloud really sucks, ugh), and also to identify the reason why Obsidian doesn’t remember my workspace layout

I’d like to learn from the community’s experience, so I kindly ask, has anyone experienced the same issue(s)? how did you fix it?

many thanks in advance

Are you using iCloud on Windows? I have this exact issue with iCloud on Windows. It works flawlessly on Mac, syncing with my iPhone and iPad.

I usually delete all workspace files except the “latest” one. Few days ago I tried deleting the entire vault from iCloud and restored it later…that seemed to do the trick but only for a day or two. After that, iCloud started behaving like iCloud again.


Yes, here are similar threads. And I’m sure I saw a similar thing at least 3-4 times now, with different wording, so I can’t find them quickly:

Hopefully some of the discussion there might help. I suggest BACKING UP first of all. Make a copy of your vault.

And then maybe move your vault outside of iCloud while attempting to clean up any duplicate files, so they don’t continue to duplicate. Otherwise I don’t think anyone has ever followed up and confirmed this worked for them. So backup, and if it works, please let us all know!

1 Like

I manually delete about 5-10 every few days.
Ditto for the recent files plugin where the data.json gets duplicated

1 Like

yes, I’m using iCloud for windows, I’m sure that iCloud on macOS is super within its own ecosystem, but iCloud for Windows is such a pain in the @ss to use; I don’t own a Mac but I still need to sync w my iPhone & iPad, idk if this is the best way to do it

I’ll try deleting all of those duplicates except the latest, but have to say that it is annoying if I have to do this every now and then

i see, so it’s an issue that many people have
are you using iCloud for Windows too?

i also have the recent file plugin, but the data.json under its folder in my vault doesn’t have the same issue

for now, I’ll just try deleting all the duplicates, thanks for reminding me, I do regularly backup everything; but this is apparently not a permanent solution, and I also have little hope for Apple to actually improve their windows software that I’m paying a monthly subscription for lol

do you know about the other issue i mentioned? workspace duplicates are small in size and don’t really cause other problems, but this is honestly more annoying

appreciate it

If you don’t need to use the official Obsidian app on your mobile devices, you may want to consider moving your vault to some other cloud like dropbox, onedrive, box, or mega and use something like 1Writer on those devices. That works well if your primary use case on mobile is simply to access your notes on the go.

1 Like

yeah, i used to use 1Writer & OneDrive on my iOS and iPadOS, OneDrive works REALLY WELL, far more stable & faster than iCloud Windows - but after waiting for a long time, the Obsidian Mobile is something that did not disappoint, it’s amazing, my use cases include editing notes, links and stuff, so i switched back to iCloud since i have a storage plan anyway

and, here we are

might need to look into the Obsidian sync if this keeps getting worse

Obsidian Sync works really well…tried it for a month or two…

1 Like

a few forum members have reported success with using iCloud software you can download directly from Apple rather than from the Microsoft store

1 Like

yeah, i am using the version downloaded directly from Apple
what do you mean by success? I mean the software works on my computer, but it just has glitches like this often

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.