Option to turn off auto-embed off attachments

Auto-embed isn’t always needed or wanted and creates extra busy work if utilizing a lot of attachments

I work in a field that requires a lot of referencing PDFs, which I mostly manage inside of Obsidian. It’s extraordinarily useful for this purpose. However, I manage the index of files within a note/notes via nested bullet lists. Having to constantly remove the embed to turn it into a simple link is exhausting.

Proposed solution

I propose a simple radio toggle in the settings to stop auto-embedding of attachments; whether drag-and-dropped outside of Obsidian or within Obsidian, using the command palette or hotkey, or any other method of adding attachments aside from simply typing the wikilink.

Ideally, there’d be a hotkey and command palette method to turn this on and off, as needed.

6 Likes

If you hold alt (on Mac, I’m not sure on Windows) while dragging a file into a note, you will get a file:/// link instead of a Wiki link. This also works on multiple files at once.

I’ll second this one. Sometimes i just want the file to import and leave a link, but NOT embed. Usually pdf’s.

That’s useful and I appreciate it, but how does Obsidian handle it if I’m utilizing links on other devices I’ve synced? I imagine it can’t use those links to point to that local file.

Your original request would also not work with Sync. I’m not sure what to tell you. Yes a local file is local.

It absolutely would work with sync if I enabled PDFs in the Sync extension. However, the recommendation you gave would simply sync a broken link.

Want to also +1 this request.

I attach videos to note that I don’t want to embed and merely reference, but because of the auto-embed, it causes Obsidian to falter when the videos are large.

+1 to have a setting option to turn off auto-embed. Having to manually remove the embed each time is annoying.

I’m back to Obsidian after a while. This auto-embed issue seems not to be fixed yet. So +1 also from me.

I work with PDFs and Tag Pages a lot, so I’m also looking for a solution here – either the proposed setting or a workaround.

As a student I need often to add several pdf to my course. It would be great to have the possibility to disable temporarily autoembed.

Workaround when several file in a same note :
Search and remplace “![[” by “[[”

1 Like