Option to disable hardware acceleration


I’m getting this previously-reported graphical issue in Obsidian (and in Chrome itself) from time to time that does not go away until I do a full reboot (and seems to come back after a certain amount of time anyway). I believe that this is an issue with Chromium and Apple’s GPUs on 16" macbook pros, as gone over in this chromium bug thread.

From that thread, it seems that a temporary stop-gap solution is to disable hardware acceleration, which has actually resolved it on the Chrome side. I can’t figure out how to disable it from the Obsidian side, and that’s likely because it’s not exposed unless the developer of a chromium application exposes it.

Can the ability to turn off hardware acceleration be an option in the Obsidian UI?

Here’s a screenshot of what I saw earlier today:


7 posts were merged into an existing topic: Chromium Display Bug - MacOS

As is seen in this bug, hardware acceleration also causes problems under certain Linux environments.

Seeing that hardware acceleration is apparently causing recurring problems for some users, a simple solution would be to add a setting option to disable hardware accelereation, so users are not left to either open Obsidian only from the command line or to manually edit their Obsidian.desktop file, which some may not even know how to locate.

A simple and unobtrusive solution that people who do not need it can easily dismiss. I know that the Slack desktop app has such a setting.