Opening Canvas from Quick Switch not working

Steps to reproduce

Create a canvas with a name e.g. “test canvas”
open quick switcher (CTRL-O)
type “test canvas”

Expected result

newly created canvas is shown and can be opened

Actual result

no results are shown


Windows + Obsidian 1.1.2

Additional information

Alternative workaround in the beginning: have ability to set default location for canvas files

works for me. Did you follow the bug report template?
Did you try no themes/no plugins or the sandbox vault?

Also you did not provide the debug info.

No I could play around with it. It seems that canvas is treated as an attachment and thus if the quick switcher setting is turned of for attachments canvas is not shown. As Canvas seems to be standard content created by obsidian, in my opinion connecting it to attachments seems not intuitive. I would like to be able to quickly go to a canvas for sure, but all the attachments easily flood the quick switcher. Perhaps you can reconsider this design choice.

And here my system info for reference:

Obsidian version: v1.1.3
Installer version: v0.14.6
Operating system: Windows 10 Home 10.0.22000
Login status: logged in
Catalyst license: supporter
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 3
Restricted mode: off
Plugins installed: 71
Plugins enabled: 37
1: Natural Language Dates v0.6.1
2: Recent Files v1.3.5
3: Review v1.6.4
4: Calendar v1.5.10
5: Dataview v0.5.47
6: Templater v1.16.0
7: Hotkeys++ v0.2.7
8: QuickAdd v0.7.0
9: Note Refactor v1.7.1
10: Tag Wrangler v0.5.5
11: Periodic Notes v0.0.17
12: Hotkey Helper v0.3.15
13: TimeStamper v1.3.0
14: Excalidraw v1.8.4
15: Remember cursor position v1.0.7
16: Table Extended v1.6.1
17: Text Snippets v0.1.2
18: Paste image rename v1.5.0
19: Tasks v1.20.0
20: Hover Editor v0.11.8
21: Carry-Forward v1.4.3
22: Obsidian Query Language v2.1.1
23: Daily notes opener v2.0.2
24: Limelight v1.1.0
25: Habit Tracker v0.3.4
26: Day Planner v0.5.8
27: Simple Embeds v1.14.0
28: Toggl Track v0.9.0
29: Trim Whitespace v0.2.2
30: Global Hotkeys v0.1.2
31: Open File by Magic Date v0.1.0
32: Kindle v0.0.13
33: Kindle Highlights v1.8.1
34: CustomJS v1.0.12
35: Kanban v1.5.1
36: Obsidian TODO | Text-based GTD v0.2.7
37: Markdown Table Editor v0.3.1

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Open a FR for this, thanks.