Open Brackets, Obsidian Not finding Page Alias

Things I have tried

Research, Reinstalling App

What I’m trying to do

I’m trying to link to a page alias, but when I type the open brackets and start typing the alias, the page doesn’t show up in the list.

I’ve tried copy/pasting the YAML exactly as I have it in other notes to be sure there’s no error and it still doesn’t work. This is what I have:

Aliases: [“Mann, 2013”]

Now, when I add that exact alias to another note in which the aliases are working, it also works, so seems the syntax is ok…

so not sure why in the note that I actually want it in, it doesn’t.

THANKS!

u need to make to use the right double quotes (“Mann, 2013” wont work, but “Mann, 2013” will)

---
Aliases: ["Mann, 2013"]
---

thank you, but I don’t see the difference. what do you mean by the right double quotes… yours look the same to me.

cheers.

I believe @efemkay is referring to needing to use straight quotes rather than curly ones.

This: "

But not this:

Angel

1 Like

tqs @Angel. yeah that what i meant. didn’t realise when i pasted as normal text it automatically changed to curly. but the one in the snippet is the correct one

2 Likes

cool, thanks, and I think this has been the cause of other problems in the past… how do I stop obsidian from using curly quotes? is this a setting in obsidian or my mac?

and futher complicating it, when I copy pasted the exact alias syntax from a note that worked, it also didn’t work, so could it be as @efemkay said in his forum post, that pasting a straight quote can result in a curly one?

and I might add, I see plugins that convert straight to curly quotes, which is nice for writing, which is what I do. But then it seems that straight quotes would be the default? I guess I’m trying to figure out what I’m doing wrong to get the alias problem.

Hmm, i guess i dont use it (quotes for yaml) often enough. I just make do with watching out how i type.

1 Like