Open a specific vault with Obsidian URI

Hello,

how can I configure this with a tiling manager like i3 or in my case with awesome wm?

I use linux manjaro with awesome wm and Obsidian as an AppImage.

I would like to open a certain vault of obsidian with a shortkey. I read the solution is to start AppImage with the uri for a special vault. How can I achieve this?

Thanks for your effort,
8tungdata

What did you try? Can you open a specific vault from the command line? In my case, I can use either obsidian or xdg-open to open the URI scheme described in the manual: Using obsidian URI

Like obsidian "URI to specific vault".

I have the “Obsidian-0.12.10.AppImage”. I can not open a special vault with the uri.

A simple Obsidian-0.12.10.AppImage URI-to-specific-vault doesn’t work.

Maybe I don’t understand the syntax. My Vault is /run/media/Drafting/. What is the correct command to open it on command line?

This is what I get:

`./Obsidian-0.12.10.AppImage://open?vault=Drafting

-bash: ./Obsidian-0.12.10.AppImage://open?vault=Drafting: Datei oder Verzeichnis nicht gefunden`

Error: File or Directory not found. With the absolute path its the same.

In my case, obsidian "obsidian://open?vault=Drafting" would be able to open the vault. xdg-open works too.

And of course, try the stuffs from the comments above our posts. They may have the solution for you. edit: Ok, this sentence doesn’t make sense because they split the original thread.

In the docs, I noticed the link to “See here for details” is a 404 error. But there is a similar page here maybe: Desktop entries - ArchWiki

Hi @santi sorry for the ping, but have you set up the Obsidian URI scheme in Linux Manjaro?

I should add instructions for this to the Meta thread.

In the meantime, @8tungdata can you let us know the following? (These are the commands for Ubuntu, YMMV)

  • how your desktop file looks like?
  • the output of xdg-mime query default x-scheme-handler/obsidian?
  • the output of xdg-settings get default-url-scheme-handler obsidian?
  • whether/where does obsidian show up in your ~/.config/mimeapps.list?
  • does the URI work when you paste it on your browser?

I know that there’s some bug with KDE (which was supposed to be fixed) which is why I can’t get it to work on Manjaro.

But with your wm it should work. (If your desktop file is correct)

I get no output of all of this commands. There is no obsidian entry in ~/.config/mimeapps.list. The URI doesn’t work in the browser. I’m using Manjaro. There is no URI configuration. I’m also using no wm with desktop files. This is the reason why I have no desktop file. I use awesom wm, this is a tiling windows manager.

https://awesomewm.org/

Seems there is no easy way to get this functionality without using something like xfce, kde or gnome? For the moment I have to give up. I’m on holidays next week. Thanks for your efforts.

I am using i3 (also a tiling wm) on Ubuntu 18.04. You need to configure the Obsidian URL for it to work. Here are some rough instructions of what I did:

I don’t know the specifics of awesome wm, but there has to be a way to do something equivalent if it doesn’t support desktop files.

1 Like

Thank you, very much. :slight_smile: :sweat_smile:

xdg-open obsidian://open?vault=Drafting opens my vault “Drafting”

I configured the obsidian URL after your instructions. It works.

2 Likes

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.