Obsidian window not appearing after installing latest installer version (0.12.19) on macOS

Steps to reproduce

  1. Download and install the latest version of Obsidian from http://obsidian.md
  2. Open the Obsidian app.

Expected result

The Obsidian loading screen should appear as normal.

Actual result

No window actually appears though Obsidian seems to be running in the background.


  • Operating system: macOS Mojave (10.14.6)
  • Obsidian version:0.12.19

Additional information

I reinstalled 0.12.16 from the GitHub releases and the window shows up again, so there seems to be something off with the latest release.

I also looked to see if the window is hidden, but it’s not.

I am not sure I can help.

First, make a backup of your vault.

  1. Install Obsidian
  2. delete $XDG_CONFIG_HOME/Obsidian/
  3. Start obsidian

I don’t think mac has $XDG_CONFIG_HOME, but I did try deleting ~\Library\Application Support\obsidian after installing Obsidian, and nothing. May I ask where $XDG_CONFIG_HOME is located on mac?


There’s no Obsidian folder in ~/Library/Preferences/

I am not familiar with all the paths used on MacOS. Other than cleaning up the old installation and maybe deleting the .obsidian folder in your vault, I am not sure what else to suggest you. We haven’t had other reports about this.

Maybe there is something in ~\Library\Cache

Nothing in ~\Library\Cache either. Have deleted all of my vault’s .obsidian folders as well as .git, and nothing.

If no solution shows up, I can wait til the next public release. Hopefully it’ll be fixed by then.

@3mbry0 did 0.13 fix it? You could try the following command too (run from Terminal)

defaults delete md.obsidian

after doing that, log out and log back in and try launching Obsidian again

Hey @luckman212 thanks for this!

Unfortunately, I’m not an insider so I can’t install 0.13.

I haven’t tried the command yet. Is there anything I can backup before running it, just in case something goes wrong? It doesn’t seem reversible :sweat_smile:

Otherwise, I can wait for 0.13 to be publicly released.

Nothing important is stored there- just window positions etc which is why I thought it might help you to reset.

If you want to see what’s in there first, you can run defaults read md.obsidian

I tried it and unfortunately it didn’t work even after logging in and logging out. Thanks anyway!

Maybe try launching Obsidian from Terminal so you can see it’s debug output - there might be something informative there


Terminal doesn’t seem to be indicating what’s wrong

2021-11-11 14:37:41 Loading main app package /Applications/Obsidian.app/Contents/Resources/obsidian.asar
2021-11-11 14:37:41 Checking for update using Github
2021-11-11 14:37:42 Success.
2021-11-11 14:37:42 Latest version is 0.12.19
2021-11-11 14:37:42 App is up to date.

Update: I just closed Obsidian and Terminal outputted more info.

(node:2155) UnhandledPromiseRejectionWarning: TypeError: Object has been destroyed
    at loaded (/Applications/Obsidian.app/Contents/Resources/obsidian.asar/main.js:526:26)
(Use `Obsidian --trace-warnings ...` to show where the warning was created)
(node:2155) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag `--unhandled-rejections=strict` (see https://nodejs.org/api/cli.html#cli_unhandled_rejections_mode). (rejection id: 1)
(node:2155) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

Not sure if that’s indicative of anything

Not sure either. I’m on 0.13.0 but I don’t get that warning upon quitting. I’m basically out of ideas (sorry). Try creating a new test user account on your system and running it from there…