Obsidian White Screen Delayed Slow Startup

All custom CSS, and Core and Community plugins were disabled, and the expected behavior remains the same.

Steps to reproduce

Just start the obsidian program from start or icon

Expected result

Obsidian Startup “Loading Workspaces” Progressbar used to show up immediately

Actual result

If the Obsidian Window was last closed in a maximised state, a white winow opens for 3 -4 seconds and then turns into obsidian default loader, which runs as usual

If the Obsidian Windows was last closed in non-maximised state (Smaller window, not occupying the entire screen ) The launch is delayed by 3-4 seconds as before, but nothing shows up on the screen

Environment

  • Operating system: Windows 10
  • Debug info:
    SYSTEM INFO:
    Obsidian version: v0.13.31
    Installer version: v0.13.31
    Operating system: Windows 10 Home 10.0.19044
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: California Coast
    Snippets enabled: 5
    Safe mode: off
    Plugins installed: 14
    Plugins enabled: 11
    1: Templater
    2: Hotkeys++
    3: Hider
    4: Note Refactor
    5: Clear Unused Images
    6: Calendar
    7: Imgur Plugin
    8: Recall
    9: Style Settings
    10: System Dark Mode
    11: Periodic Notes

REMINDER: ALL PLUGINS and THEMES WERE DISABLED


Additional information

The Problem started when I updated my installer build to 13.30/13.31 (I dont remember which) but only a few days ago… my app was already updated to the latest build, but the installer was behind (12.). So I thought what the hell and updated it, No other performance issues or problems, just startup is no more instant, and takes 3-4 seconds now.

Could be an electron problem, from what i have seen with electron apps. :woman_shrugging:

Video of Problem: Obsidian Freezing on Startup

1 Like