Obsidian Version for EeePC 1000HE with Intel Atom N280 (32 bit) searched

The Linux AppImage downloads from Obsidian not worked / started on my EeePC 1000HE with Intel Atom N280 processor. I think the problem is ,the AppImage is only for 64 bit systems and not worked on my 32 bit system…
Where can I find a version from Obsidian for my 32 bit EeePC 1000HE…?
The trails with flatpak and wine obsidian versions also not worked…

Please help me…:wink:
“Where” can compile/ build… an version from Obsidian for my EeePC… :wink:

CLI output:

worker@debianEeePC:~/Obsidian$ sudo ./Obsidian-1.4.16.AppImage
[sudo] Passwort für worker:
./Obsidian-1.4.16.AppImage: 1: �: not found
./Obsidian-1.4.16.AppImage: 2: }�P7pys�H��_f��h: not found
./Obsidian-1.4.16.AppImage: 1: �b�@@: not found
./Obsidian-1.4.16.AppImage: 1: ELFAI: not found
./Obsidian-1.4.16.AppImage: 19: Syntax error: Unterminated quoted string
worker@debianEeePC:~/Obsidian$

Sorry, we don’t make it.

Oh, why don’t you can make it? Needed Obsidian to many resources (RAM, processor count, …) ?

Very few computers these days are still using 32-bit x86 CPUs, and many older 32-bit x86 computers don’t have enough RAM, CPU, or GPU resources to run modern applications effectively or at all. Many software projects have dropped 32-bit Linux support due to this, including Electron.

3 Likes

Thank you…
Danke, wenn ich besser Englisch könnte, würde ich auf Englisch antworten, sorry, … verstehe ich alles was du sagst, allerdings ist es schade, das damit für viele Anwendungen z.B. im “Text- /Büro-” Zusammenhang die ältere oft 32bit HW unnötig zum “Alten Eisen” gezwungen wird, obwohl diese durchaus in der Lage wäre viele Anwendungsfälle gut abzudecken… dass würde jedoch voraussetzen nicht Bibliotheken / Werkzeuge… zur Programmentwicklung (oft unnötig) aufzublähen…
Wenn ich mich erinnere, das ich meine Diplomarbeit (1992/3 schon zu Neuronalen Netzen :wink: auf einem Atari STE mit 4 Mhz Takt und Disketten-Laufwerk geschrieben habe und dieser sich an vielen Stelllen performanter anfühlt, wie manche Anwendung unter Windows / Linux heute, sollte uns das zu denken geben… Resourcenverschwendung/ “Wettrüsten” / Nachhaltigkeit…
Der EeePC hat eine hervorragende Tastatur, eine Akku-Laufzeit > 9 h und ist nicht sehr groß, es ist sehr schade, dass es mir nicht möglich ist, AUCH auf diesem System Obsidian einzusetzen…

1 Like

It is a shame. Fortunately, the format the notes are stored in is compatible. Any 32 bit text or Markdown editor will be able to work in the vault.

So nothing is forcing the computer to the Alten Eisen. But I agree, there is constant steady pressure. One must find or make good simple software to run on these systems. Vimwiki and Emacs first come to my mind.

Interesting to read about your perspective from the 90s!

1 Like

Thank you very much… I think so… :wink:

When I was on Linux, before I found Obsidian, I used Geany, a “lightweight IDE” (fancy text editor). It can search within folders and has a customizable context menu action which I connected to a shell script to let me open file paths as if they were links. A different script could be used with the custom action to open wiki links instead. It looks like Geany still supports 32-bit systems.

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.