Obsidian URI Handling Doesn't Open Active Window (Linux)

What I’m trying to do

Using the url obsidian://open?vault=VaultName I want to open a vault, or open specific notes with more parameters as described on Using Obsidian URI - Obsidian Help

My System

I’m running Manjaro OS, and I’m using AwesomeWM as my window manager.

Things I have tried

The XDG x-scheme-handler/obsidian is set to my obsidian.desktop entry. I’ve tried a few different versions of the supported Obsidian URIs.

What happens

Before opening URI:

After opening URI:

A second window opens, which becomes stuck on this “Loading cache…” screen, instead of focusing the existing instance of the vault. I’ve also done this with a link to a specific note but the same thing happens.

I suspect something in the way that Obsidian checks for an existing instance is having an issue here. Perhaps AwesomeWM or X11 is somehow interfering with it.

Any ideas? TIA

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.