Obsidian Publish: Publish.css is stripped from Password Protected Sites

publish.css seems stripped from password protected sites.

Steps to reproduce

  1. First, check developer tools in a non-password protected site to confirm publish.css is loaded.
  2. Password protect site in Publish site settings.
  3. Reload Publish site in browser.
  4. Confirm that developer tools is not loading a publish.css

Did you follow the troubleshooting guide?

Yep! Not really applicable here.

Expected result

I expect publish.css to be honored whether or not password protection is enabled.

Actual result

publish.css is not loaded at all.

Environment

Chromium (ARC)
Safari (macOS)


Additional information

Developer tools showing publish.css loaded on a non-password protected site:
CleanShot 2024-07-09 at 21.49.23

Developer tools showing publish.css is not loaded on a password protected site:
CleanShot 2024-07-09 at 21.52.39

May also be related to this older bug.

Adding some more after additional testing.

So… its interesting. It may also be a cache issue, because it worked when adding publish.js. It would seem silly that adding a publish.js would fix it. So I checked another computer that has never loaded the site. It loads without the publish.css and publish.js. Rapidly reloading over and over eventually triggers it, even in private browsing.

So less of a problem, but still not great for the first time visit experience.