Obsidian Publish incorrectly prompts user while building an INCLUSION list of folders

Steps to reproduce

  1. publish changes
  2. manage publish filters
  3. click ‘manage’ button under the ‘included folders’ section
  4. attempt to add a folder that is already added

recording of these steps shown here: Screen-Recording-2023-01-01...

Expected result

The program prompts the user: This folder is already included.

Actual result

The program incorrectly prompts the user - implying that an EXCLUSION list is being built; causing confusion and then minor resentment.

Currently the prompt reads: This folder is already EXCLUDED.

Environment

  • Operating system:
  • Debug info:
    SYSTEM INFO:
    Obsidian version: v1.1.9
    Installer version: v1.1.8
    Operating system: Windows 10 Pro 10.0.19044
    Login status: logged in
    Catalyst license: none
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Restricted mode: off
    Plugins installed: 15
    Plugins enabled: 13
    1: Checklist v2.2.12
    2: Editor Syntax Highlight v0.1.3
    3: Copy button for code blocks v0.1.0
    4: Emoji Toolbar v0.3.2
    5: Recent Files v1.3.5
    6: Pandoc Plugin v0.4.1
    7: Linter v1.10.1
    8: Buttons v0.4.19
    9: Obsidian Charts v3.7.1
    10: Breadcrumbs v3.6.4
    11: Full Calendar v0.9.5
    12: Notion-Like Tables v5.0.5
    13: Excel to Markdown Table v0.4.0

RECOMMENDATIONS:
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.


Additional information

I did also try this with all plugins disabled, didn’t help; I would have tried the sandbox but I also tried this on a separate bug I reported yesterday and it did not help so my confidence is just generally low on this entire build so I did not take the time.