Obsidian on macOS Big Sur (11.2.1) becomes laggy

Hi all.

After upgrading to macOS Big Sur, Obsidian becomes so laggy. When I’m typing, it sometimes needs 2-3 seconds to complete. I could not find a pattern that will explain when it happens.

I found a similar problem happening in VS code terminal. The suggested solution is running a command like the below.

codesign --remove-signature /Applications/Visual\ Studio\ Code.app/Contents/Frameworks/Code\ Helper\ (Renderer).app

Source: Fix Terminal Lags In VsCode 1.15.1 - DEV Community

Do you suggest running a same command on “/Applications/Obsidian.app/Contents/Frameworks/Obsidian Helper (Renderer).app” ?

I do not know how to reverse the command if anything goes worse.

It is so annoying to wait when note-taking. Any help will be appreciated.

I tried the command. There are no lags for 2 days. I believe there is something special about editors in Big Sur.

what’s your installer version?

Obsidian v0.10.13

settings>about. there are two versions

Current version: v0.10.13
(Installer version: v0.10.13)

Ok, so I don’t know. It’s strange that you are the only one reporting this.

OK, this is an upstream bug with electron. We will fix it once they release a fix.

@cagdur are you using third party plugins? try disabling them.

The solution is enough for me for now. However, it is good to hear that for the long term. Obsidian takes place in most of my daily work.

I have tried to disable all third party plugins but it did not work.