Obsidian on iPad acting weird with external keyboard

UPDATE: It appears this is a problem with the iPad, or with the Obsidian installation on the iPad. Exactly the same thing happens when I connect my Apple Magic Keyboard to the iPad. It does not happen with Obsidian on the iPhone.

What I’m trying to do

I connect my iPad Mini to my Logitech MX Keys Mini keyboard and use it frequently, including with Obsidian. Today, after editing the note for a while, I got a colored border around the note, the keyboard stopped responding, and I got a pair of arrows at the top of the screen that let me move between the current note and the next and previous. Something similar happened a couple of weeks ago, but I discovered the keyboard was low on power, and after recharging it worked fine. Today I confirmed the keyboard had plenty of power. Turning the keyboard off and on again didn’t help. I’m on the lastest iPadOS, and the keyboard works fine with my laptop (I haven’t tried it with Obsidian on my iPhone yet). Any clues?

Things I have tried

Made sure the keyboard was charged. Turned the keyboard on and off.