Obsidian not remembering dark-mode preference

A weird thing that started happening when I switched from the Gnome desktop manager to a window manager is that Obsidian no longer remembers that I like dark mode.

It’s an easy work around, just assign switch to dark mode to a keybind, but it’s weird behavior and I thought I’d ask.
I don’t see a setting for light/dark in .obsidian/appearance.json, my file looks like this:

  "baseFontSize": 16,
  "cssTheme": "Minimal",
  "interfaceFontFamily": "",
  "monospaceFontFamily": "Fira Code",
  "textFontFamily": "",
  "theme": "obsidian",
  "translucency": true,
  "enabledCssSnippets": [
  "accentColor": "#8758f3",
  "showViewHeader": false,
  "nativeMenus": false

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.