Obsidian not flushing files to iCloud Drive

Please describe what you’re trying to accomplish so the community can better help you. Sometimes the solution you have in mind is not necessarily the best option, in which case knowing some background info can let others come up with creative solutions for your use case.

Please continue below this line. →

Hi all, this might be more of a bug, but I don’t have enough willpower to try to reproduce this, largely because I might lose all of my recent data. I think that ever since I upgraded to the latest Obsidian version on the Mac (which required me to download a .dmg file and replace the existing app), Obsidian has stopped (reliably, more on this later) flushing files to the iCloud vault folder! I’ve restarted the app plenty of times, but the files just won’t show up. This leads to another issue where these files aren’t available on my mobile devices, and I am scared to write anything in Obsidian from the mobile devices to avoid any overlap.


As I was writing this topic, I had already tried disabling and enabling Obsidian sync on iCloud on the Mac and restarted the app a couple of times. NADA. I also tried File » Open Vault, and I believe that may have finally triggered a “flush” to the iCloud drive because I can finally see those files for the first time in at least a week. The file uploads to iCloud however seems to be stuck… which might be an Apple problem.

Anyhow, has anyone else witnessed the issue mentioned in the first paragraph? If so, have you figured out a resolution?