Obsidian IOS-1.2.2 Crashes

[Bug] Obsidian IOS-1.2.2 Crashes Reload-App doesn’t solve the problem

iOS 12.3.1

Obsidian Mobile version: v1.2.2

Starting a new vault or opening an existing one, today’s updated version of Obsidian crashes on start up. Restarting, Re-installing didn’t solve the problem. See the screenshot below.

Is there a way I can re-install the previous version?
Or is there somewhere I can download the IPA file for Obsidian version 1.2.0 ?


You have quite an old iOS version, Can you update iOS?

Does it crash on start or are you able to create a new vault?

ok, I can confirm this is due to an API not correctly implemented in older version of iOS.

I am another stupid one, who decided to update. My iOS is 12.4.1. No, I cannot update iOS, my iPhone is too old. Please, give us some chance at least to restore to the previous version of Obsidian. It is very difficult to go without all my notes.

We are testing a release that works around this iOS bug.

Thanks for that.

I can’t upgrade past iOS-12 - older phone.

Obsidian-1.2.2 will let you create a new vault and receives the same error as existing vaults from version 1.2.0 or v1.1.1. The AppStore recommends iOS 12.1 or later for the current Obsidian version 1.2.2.

If the bug is not repairable is there a link where we can download v1.2.0 as an IPA file? Thanks.

Same - updated as the previous versions of Obsidian worked. Plus, it’s recommended for iOS 12.1 or later.

I tried from my backup and was unable to transfer the previous version. One search suggestion was - IF - I had my apps backed up with an app like AnyTrans.app or similar, it’s easier to roll back an app. I know that this doesn’t help you or more today - it’s probably a good strategy going forward to keep apps running.

A new release was sent to the app store. Let me know if it works when you get it.

Excellent! Thank You.
v1.2.3 is working on iOS 12.1.

For those that might not yet have access to the updated file, if it’s not yet in the AppStore in your location or country, I accessed v1.2.3 via the AppStore’s Account setting - Purchased - list.

IOS 12.4.1 - everything works well now. Tested local vault and another one in iCloud. Thank you very much for your work.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.